Laravel

windows多个版本php下使用composer

由于打算在新服务器上使用php7.1的来做环境,本地机器上就有包括原来的5.6和7.1共存的情况,在使用composer的时候,因为设置的环境变量,自动会调用原来的php环境,导致需要高版本php的项目出现报错。 问题 那如何才能在多版本的情况下使用composer而互不干扰呢? 解决 先去composer官网下载一个composer.phar文件,放到某个地方,我是放在d:/xampp/php下 […]

Lumen环境Windows下Xampp环境安装Composer

TP框架之后想学一下Laravel“精简版”Lumen,现在配置环境,需要安装PHP依赖管理工具Composer,我本地环境是Xampp,一步一步来。 准备工作 打开PHP配置文件E:\xampp\php\php.ini确认以下模块已开启(移除前面的分号)。 extension=php_openssl.dll, extension=php_curl.dll, extension=php_socke […]

Scroll to top